-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Artwork
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login



Sponsoring


-
- Content .- Fans  . 

Kopete Emoticons Manager

   0.2  

KDE Improvement

Score 82%
Kopete Emoticons Manager
zoom


Link:  http://
Downloads:  4684
Submitted:  Mar 21 2007
Updated:  May 25 2007

Description:

This is a patch that include an emoticons theme manager into kopete so you can add edit and remove emoticons, you can also add custom emoticons that you receive during a chat by right clicking it

i've also used part of the code of the patch founded here http://rockman.altervista.org/?p=patches.php

in order to apply the patch you have to download kopete svn http://kopete.kde.org/svnaccess.php
and then from kopete directory something like .../kdenetwork/kopete you have to do "patch -p0 < /path/to/kopete.patch"

if you get errors like
Quote:
undefined reference to `EmoticonsEditDialog::EmoticonsEditDialog(QWidget*, QString, char const*)'

try to to do make -f Makefile.cvs




Changelog:

- Rewritten to use qdom instead of regexp, it should works much better!




LicenseGPL
Source(patch)
Send to a friend
Subscribe
Other  Artwork  from LeeSieLung
Report inappropriate content



goto page: prev   1  2  3  4  5  6 

-
.

 can't see other's

 
 by zouzou85 on: May 3 2007
 
Score 50%

well, the patch applied fine and everything compiled just fine. but the problem is that i can't see other custom emoticons when others send them to me, and when if i import an emoticon, others won't see it when it is sent. they see it as text.


Reply to this

-

 Re: can't see other'

 
 by LeeSieLung on: May 3 2007
 
Score 50%

you have to enable it under msn account option, i don't know if other protocols support this


Reply to this

-
.

 Don't work

 
 by leven on: May 7 2007
 
Score 50%

Don't work for me.. =(

Please, Can you send me the compiled files?


Reply to this

-
.

 Erm

 
 by Spider-k on: May 9 2007
 
Score 50%

What do I do exactly, after I install Kopete SVN?


Reply to this

-

 Re: Erm

 
 by LeeSieLung on: May 9 2007
 
Score 50%

if you did everything right you just have to run it :D


Reply to this

-

 crash

 
 by marseillai on: May 22 2007
 
Score 50%

now using kde 3.5.7 i've add your patch and i've the same error :
kopete: symbol lookup error: /usr/lib/kde3/kcm_kopete_appearanceconfig.so: undefined symbol: _ZN19EmoticonsEditDialogC1EP7QWidget7QStringPKc


Reply to this

-
.

 Re: crash

 
 by LeeSieLung on: May 22 2007
 
Score 50%

did you set the right prefix with ./configure --prefix=/usr or ./configure --prefix=`kde-config --prefix` ? because otherwise it defaults to /usr/local


Reply to this

-

 Re: Re: crash

 
 by marseillai on: May 22 2007
 
Score 50%

sorry for disturbing i've made a mistake in my package wich is just repair now. it look so cool now! even if i have a bug that i've just reported about editing wich don't apply.


Reply to this

-

 problem

 
 by Superstoned on: May 26 2007
 
Score 50%

I do have the ability to save emoticons, but there is no 'edit theme' button in the emoticon configure location, like in your screenshot. what is wrong?


Reply to this

-

 Re: problem

 
 by LeeSieLung on: May 26 2007
 
Score 50%

have you get some errors during patch?
try to open kopete/config/appearance/appearanceconfig_emoticons.ui
and see if there is this section after get new themes and before install theme files

Quote:

<widget class="QPushButton">
<property name="name">
<cstring>btnEditThemes</cstring>
</property>
<property name="text">
<string>&amp;Edit Theme...</string>
</property>
<property name="whatsThis" stdset="0">
<string>Edit the selected emoticons theme</string>
</property>
</widget>


Reply to this

-

 Re: Re: problem

 
 by Superstoned on: May 26 2007
 
Score 50%

This is what the guy building my packages gets during compiling (it turned out the patch wasn't there, he was unable to add it).

/bin/sh ../../../../libtool --silent --tag=CXX --mode=link g++ -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -march=i686 -pipe -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -o kcm_kopete_appearanceconfig.la -rpath /opt/kde/lib/kde3 -module -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -avoid-version -module -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -R /opt/kde/lib -R /opt/kde/lib -R /opt/qt/lib -L/opt/kde/lib -L/opt/qt/lib kcm_kopete_appearanceconfig_la.all_cpp.lo ../../../libkopete/libkopete.la ../../../kopete/chatwindow/libkopetechatwindow.la -lktexteditor -lkutils -lknewstuff
.libs/kcm_kopete_appearanceconfig_la.all_cpp.o: In function `AppearanceConfig::editSelectedEmoticonTheme()':
kcm_kopete_appearanceconfig_la.all_cpp.cpp:(.text+0xe171): undefined reference to `EmoticonsEditDialog::EmoticonsEditDialog(QWidget*, QString, char const*)'
collect2: ld returned 1 exit status

The KDEMOD packagers from Arch Linux have tried to add your patch, but they couldn't get it to run. If you want to track down the bug, you can contact them at http://bbs.archlinux.org/viewtopic.php?id=23319&p=40


Reply to this

-

 Re: Re: Re: problem

 
 by Superstoned on: May 26 2007
 
Score 50%

and I see this is the same problem the guy below has.


Reply to this

-
.

 does not work

 
 by jazztyle on: May 26 2007
 
Score 50%

the patch does apply on 3.5.7, but the compilation breaks with this error:

Quote:
/bin/sh ../../../../libtool --silent --tag=CXX --mode=link g++ -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -march=i686 -pipe -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -o kcm_kopete_appearanceconfig.la -rpath /opt/kde/lib/kde3 -module -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -avoid-version -module -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -R /opt/kde/lib -R /opt/kde/lib -R /opt/qt/lib -L/opt/kde/lib -L/opt/qt/lib kcm_kopete_appearanceconfig_la.all_cpp.lo ../../../libkopete/libkopete.la ../../../kopete/chatwindow/libkopetechatwindow.la -lktexteditor -lkutils -lknewstuff
.libs/kcm_kopete_appearanceconfig_la.all_cpp.o: In function `AppearanceConfig::editSelectedEmoticonTheme()':
kcm_kopete_appearanceconfig_la.all_cpp.cpp:(.text+0xe171): undefined reference to `EmoticonsEditDialog::EmoticonsEditDialog(QWidget*, QString, char const*)'
collect2: ld returned 1 exit status


the configure line looks like this:

./configure --prefix=/opt/kde --disable-debug --disable-testbed --disable-smsgsm --disable-debug --enable-final


Reply to this

-

 Re: does not work

 
 by LeeSieLung on: May 26 2007
 
Score 50%

i have just compiled the official 3.5.7 release with the same configure options and i didn't get any errors


Reply to this

-

 Re: Re: does not work

 
 by jazztyle on: May 26 2007
 
Score 50%

could it be that your patch interferes with these 2 patches?

kopete relading kit:
http://www.kde-apps.org/content/show.php/Kopete+Reloading+Kit?content=49765

kopete uvc webcam support:
http://www.alexandredenis.net/software/kopete-uvc/

we have no other patches applied and are also using the official 3.5.7 tarballs...


Reply to this

-

 Re: Re: Re: does not

 
 by LeeSieLung on: May 26 2007
 
Score 50%

i have kopete reloading kit too but not the other one, anyway i'm installing archlinux on vmware right now to test


Reply to this

-

 Re: Re: Re: Re: does not

 
 by jazztyle on: May 26 2007
 
Score 50%

please notice that we are not using the official kde packages from arch but the kdemod packages...

you can access the latest ones by adding this entry to your /etc/pacman.conf

[kdemod]
Server = http://kdemod.ath.cx/repo/testing/i686

after doing that you can install it with

pacman -Syu
pacman -S kdemod

more info here: http://kdemod.ath.cx/


Reply to this

-

 Re: Re: Re: Re: does not

 
 by jazztyle on: May 26 2007
 
Score 50%

please notice that we are not using the official kde packages from arch but the kdemod packages...

you can access the latest ones by adding this entry to your /etc/pacman.conf

[kdemod]
Server = http://kdemod.ath.cx/repo/testing/i686

after doing that you can install it with

pacman -Syu
pacman -S kdemod

more info here: http://kdemod.ath.cx/


Reply to this

-

 Re: Re: Re: Re: does not

 
 by dunkelstern on: May 26 2007
 
Score 50%

Well i traced it down a little bit further.

Seems to be a Makefile issue.

ltmain.sh doesn't generate a emoticonseditdialog.lo and it doesn't compile emoticonseditdialog.cpp, so the symbol is missing afterwards while linking.

But I don't know how to fix it as I am no automake/libtool professional.


Reply to this

goto page: prev   1  2  3  4  5  6 

Add commentBack






-

-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore




 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Artwork
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
News RSS   
Discussion RSS   
Events RSS   

Participate
Groups
Forum
Add Artwork
Public API
About KDE-Look.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2001-2014 KDE-Look.org Team  
All rights reserved. KDE-Look.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.