KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    Linux42.org    OpenSkillz.com   


- Content .- Fans (44) .- Knowledge Base  . 

Root Actions Servicemenu


KDE Service Menu

Score 90%
Root Actions Servicemenu

Root Actions Servicemenu

Root Actions Servicemenu

Link:  http://
Downloads:  35430
Submitted:  Nov 8 2006
Updated:  Mar 22 2016


Version: 2.9

- You need to have "ruby" installed for Automatic installation to work
- Make sure you get the latest version, the automatic download from dolphin seems to download a really old version (2.7.3) for some mysterious reason. Manual download from kde-apps/kde-look will guarantee you'll get the latest version.

- From version 2.8 onwards, Root Actions only supports KDE4 or later...Files from version 2.7.3 are included in the package for KDE3 users.
- My mail address can be found in the README file in the package if you wish to contact me for translations or feedback (You can of course also post a comment here)
- I can't test the menu on KDE3 anymore, so I can't guarantee the menu works 100% on KDE3
- Full Kf5 support is work in progress, but the menu should work on kf5 as is.


Root Actions servicemenu provides a convenient way to perform several actions 'as root', from the right-click context menu in KDE filemanagers.

It aims to be distribution agnostic, if you experience issues in your distribution, drop me an email describing the issue.

The menu needs a properly configured kdesu/kdesudo to work (kdesudo is preferred, for some added functionality, like remembering password for a period of time...timeout is configurable by sudo settings)

Any comments, criticism and improvement suggestions welcomed :)

Included in the download are .desktop file versions for KDE3 konqueror, KDE3 dolphin, KDE4 and KF5 (both konqueror and dolphin) and an importable user action xml file for krusader KDE4...see installation for details.


I've dropped version 1.x from the package since 2.x is stable and can do a lot more than 1.x. If you're still interested in the 1.x version, drop me a mail and I'll send it to you.

Thanks to:
Stefan Majewsky - German translation (1.1.x and 2.x)
Pierre Buard - French translation (1.1.x)
Guillaume Millet &
Jean-Marc Detourmignies - French translation (2.x)
Alessio - Italian translation (1.1.x)
Massimo Pissarello - Italian translation (2.x)
João Pedro Gomes - Portuguese translation (2.x)
Viruscg - Brazilian Portuguese translation (1.1.x amd 2.x partial)
Eduardo Grau - Spanish translation (1.1.x and 2.x)
Kenny Verstraete - Dutch translation (1.1.x and 2.x)
Paul Körössy - Hungarian translation (2.x)
nikt_taki - Polish translation (2.x)
Andreas Nordal - Norwegian translation (2.x)
Jakub Matas - Czech translation (2.x)
Donatas Glodenis - Lithuanian translation (2.x)
Mladen Pejaković - Serbian translation (2.x)
Netrebin Alexey - Russian translation (2.x)
Cihat Imamoglu - Turkish translation (2.x)
Manuel Tortosa Moreno - Catalan translation (2.x)
Neo Tet - Greek translation (2.x)
Adrián Chaves Fernández - Galician translation (2.x)
Mihael Simonič - Slovene translation (2.x)
Niklas Åkerström - Swedish translation (2.x)

Essential: (these should already be installed on a standard KDE installation)
perl -the script is written in perl
kdesu | kdesudo -to gain administrative privileges
kdialog -to show dialogs
kreadconfig -to read kde configuration
dolphin | konqueror -filemanager
kwrite | kate -editor
ark -handles compression

krename -for multiple file (batch) renaming
krusader -to use the included krusader actions
xdg-utils -for default application support (2.5.x-)


Some distributions have packages available in either their main repos or community repos. For easy installation and possible distro specific patches you can use them if available. Manual installation instructions below:

Version 2.3 ->
1. Uncompress the rootactions-servicemenu.pl script in Root_Actions_2.x to a directory in your $PATH. /usr/local/bin or /usr/bin are two valid options. Make the script executable (if it's not).

2a. (Konqueror for KDE3) Uncompress the three .desktop files in /konqueror-KDE3 to ~/.kde/share/apps/konqueror/servicemenus (This will enable the menu for individual users, if you wish to enable the menu for all users, copy the files to /usr/share/apps/konqueror/servicemenus instead).

2b. (Dolphin for KDE3) Uncompress the two .desktop files in /dolphin-KDE3 to ~/.kde/share/apps/d3lphin/servicemenus (This will enable the menu for individual users, if you wish to enable the menu for all users, copy the files to /usr/share/apps/d3lphin/servicemenus instead).

2c. (Dolphin and Konqueror for KDE4) Uncompress the two .desktop files in /dolphin-KDE4 to your kde4 servicemenu folder (possibly ~/.kde/share/kde4/services/ServiceMenus...although $KDEHOME [".kde"] can be something else in your distribution). If you wish to use konqueror instead of dolphin as your filemanager, edit 10-rootactionsfolders.desktop by changing 'dolphin' to 'konqueror'.

2d. (Dolphin and Konqueror for Kf5) Copy the two .desktop files in /dolphin-KDE4 to your kf5 servicemenu folder (likely ~/.local/share/kservices5/ServiceMenus). If you wish to use konqueror instead of dolphin as your filemanager, edit 10-rootactionsfolders.desktop by changing 'dolphin' to 'konqueror'.

2e. (Krusader for KDE4) Import krusader_rootactions.xml file in /krusader-KDE4 with krusader's action manager.

----Available Actions----------------------------------------------------------------

Version 2.x
- Open Terminal Here (folders) - open a root terminal session in chosen folder
- Open in File Manager (folders) - open chosen folder(s) in file manager
- Open as Text (files) - open chosen folder(s) in text editor
- Open With ... (both) - open chosen items in a program of your choice

- Copy (both) - copy a single file or folder (ADDED in 2.1)
- Move/Rename (both) - if multiple items selected and a batch renamer installed (default is krename) start renamer, otherwise use a simple move/rename dialog
- Compress (both) - Compress selected files/folders (ADDED in 2.7)
- Delete (both) - Completely removes chosen items (as this is potentially hazardous, there is an extra confirmation dialog), handy for removing back-up files etc.

- Ownership to Root (both) - change ownership of chosen items to root:root
- Ownership to Active User (both) - change ownership of chosen items to current user
- Ownership to ... (both) - change ownership of chosen items to UID:GID of your choice

- Change Permissions (both) - change permissions of chosen items
If only a single folder is selected, permissions/ownership can be set recursively. If changing permissions recursively, files are only set executable if they already are executable (Otherwise all files in a directory would be set executable if the parent folder is set executable, which is necessary for the folder to be accessible)

----Translating and customizing:-----------------------------------------------------

Read the README file in the package for instructions on translating and customizing the menu


This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2, or (at your option)
any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
02110-1301, USA.


2.9 KF5 fixes
- Support for kf5-kdesu not in $PATH
- fixes in installer/uninstaller scripts
- workaround: use --nofork to open konsole as root

2.8.7 KF5 installer fix
- Fix installer script (and uninstaller) for kf5 (detect both kde4 and kf5 and install the .desktop files as necessary).
- add version number to the script

2.8.6 KF5 update & bugfix
- kf5 default application fix
- Really, really, really fix the --caption issue
- Updated README to include plasma5/kf5

2.8.5 Root reminders back for KDE4 (Really fix it this time)
- Added back root reminders for KDE4 (thanks to Caldazar for the patch), haven't found a way to add them to KF5 apps.

2.8.4 Root reminders back for KDE4
- Bad upload
2.8.3 KF5 quick fix
- Removed root reminders for now because of kf5/qt5 compatibility (no "--caption" option support)
- I'll try to add them back if I find a way to do that. TIP: Setting a different theme/color scheme for root will help you distinguish root apps even without the reminders.

2.8.2 Hopefully refixed the issue originally fixed in 2.7.4/2.8 and reverted in 2.8.1
- Using dbus-run-session, which is a better solution than dbus-launch.
- dbus-run-session is only available in dbus 1.8.x >, so the fix will only work with newer dbus releases, but the menu will still work with older versions (but the bug is obviously not fixed with that version).

2.8.1 "Out with the new, in with the old and tested" -release
- Revert "dbus-launch fix" in 2.7.4/2.8 as this is a suboptimal solution to the problem see "Known Issues". I'll revisit the original issue once dbus-run-session trickles down from upstream dbus.
- Reorganize package to move KDE3 files to a separate directory (Still hoping to get to that code clean-up part on the KDE4 version)

2.8 Reupload 2.7.4 as 2.8 since this version does not support KDE3 anymore (KDE3 files from version 2.7.3 are still included in the package for those that use KDE3)

2.7.4 Bugfix
- Use dbus-launch when starting applications as root (should fix dbus issues like not being able to open files from file manager that was opened as root) REVERTED in 2.8.1

2.7.3 Bugfix
- Fixed GHNS installation bug in 2.7.2 (forgot to update install script)

2.7.2 Translation release
- Added Swedish translation

2.7.1 GHNS bugfix & translation release
- GHNS: Create servicemenu directory (if it doesn't exist) with the install script
- Added Slovene translation

2.7 (Stable)
- Improve filemanager and texteditor fallbacks if xdg-mime fails to detect default applications
- Changes from 2.6:
1. Compress action (using ark)
2. GHNS installation in KDE4 dolphin
- GHNS installation is still a recent addition, so there may be issues with it, but it should be safe to try (the worst thing that should happen is that the installation fails).
- 2.7 is likely the last version that supports KDE3. I can't test the menu on KDE3 anymore, and dropping KDE3 workarounds would allow me to clean up the code. I'd still include 2.7 for KDE3 but no new features.

2.6.99 (2.7 RC2)
- Try removing version number from the tarball to see if it fixes a few issues with GHNS
- Edit GHNS scripts accordingly

2.6.98 (2.7 RC)
- Fix install/uninstall scripts when using kdesu or xdg-su

2.6.96 (2.7 beta4)
- Fix install/uninstall dialogs in older versions of KDE (pre 4.6)
- Uninstallation dialog made a bit more informative
- Small fixes in the install/uninstall scripts
- Test removing the extract-directory in $KDEHOME/share/apps/servicemenu-download/ when uninstalling, dolphin's servicemenu uninstallation doesn't seem to do that for some reason.
- No changes to the servicemenu itself.

2.6.94 (2.7 beta3)
- EXPERIMENTAL: Added install/uninstall scripts for GHNS in dolphin (for testing only)
- No changes to the servicemenu itself.

2.6.92 (2.7 beta2)
- Bytesize bugfix to fix an issue with kdesu on KDE SC 4.6

2.6.90 (2.7 beta1)
- Added "Compress" menu option, brings up ark compression dialog (as root) to choose filename, format etc.
- Consider compress option a beta feature...all testing feedback welcome.

2.6 "Stable"
- Fixed bug with default application detection on desktop files with kde4-prefix

2.5.92 (2.6_beta2) (hopefully just) temporary bugfix
- removed "--overwrite" option from normal copy and move operations (fix error in older versions of KDE). The "advanced" noninteractive mode still uses the option (So it'll work on KDE SC 4.5 only).

2.5.90 (2.6_beta1) kde-cp and kde-mv
- Use kde-cp and kde-mv (if available) instead of cp and mv (This should prevent accidental overwrites by bringing up KDE's overwrite dialog). If you prefer the old "noninteractive" behavior, change $CPDIALOGS to "false" in the rootactions-servicemenu.pl script (recommended for "advanced" users only)
- Some optimizations on the default application checks (removing redundancies)
- Refreshed requirements. xdg-utils is an optional requirement (default application checks need it, but the menu will work without it)

2.5.0 (Default applications, TESTING)
- KDE4 desktop files should now use your chosen default applications for "File Manager" and "Text Editor" actions.
- As I cannot test the changes in KDE3, KDE3 desktop files still use hardcoded applications (which you can change by editing the desktop files)
- As this also includes some changes in the code, it may contain bugs (please report if you run into any). It should work, but consider this a testing release (there is only so much I can test myself).

2.4.11 Bugfix
- Changed "terminal" icon to "utilities-terminal" in KDE4 desktop files (and krusader xml)...fixes missing icon in "open terminal here" action for KDE SC 4.5
- Also made KDE3 desktop files consistent in using konsole icon

--Full changelog included in the download---

Send to a friend
Other  Artwork  from kubicle
Report inappropriate content

goto page: prev   1  2  3  4  5  6  7  8  9  10  11  12 


 Maybe an installation script ?

 by srog on: Jan 24 2011
Score 50%

The Dolphin is offering an option to download/install: Dophin > Configure Dolphin > Services > Download New Services.

Those users who are using the "Dolphin Download New Services" action are wondering why it is not working.

The Rootactions has good installation instructions but they are not showing when you are using "Dolphin Download New Services", :(

The installer is using a (ruby) script /usr/bin/servicemenuinstallation. And the installation script is looking:

# try: install-it.sh
# try: install-it
# try: installKDE4.sh
# try: installKDE4
# try: install.sh
# try: install

Take care

Reply to this


 Re: Maybe an installation script ?

 by kubicle on: Jan 27 2011
Score 50%

Thanks for the suggestion Rog.

I'll look into it, but something tells me that the need to copy the perl script into a root owned directory (/usr/bin) might provide a few obstacles for the install script (and I'm not confortable with installing the script under $HOME security-wise).

I'll see if I can make an install script that can handle it nicely.

All suggestions welcomed :)

Reply to this


 Re: Re: Maybe an installation script ?

 by srog on: Jan 27 2011
Score 50%

The Dropbox ServiceMenu (http://kde-apps.org/content/show.php?content=124416) 3rd page. "KHNS by TheUserK on: Jun 8 2010".

Has info of the service-menu-installation via the Dolphin/Konqueror. It has nice install/deinstall example scripts but they are for the non-root.

The "Dolphin Download New Services" is not working at here. (KDE 4.4 - 4.6). The servicemenuinstallation is dying with the "service menu installation failed" error.

A bug report for the Ubuntu: https://bugs.launchpad.net/ubuntu/+source/dolphin/+bug/667704.

Reply to this


 Re: Re: Re: Maybe an installation script ?

 by kubicle on: Jan 27 2011
Score 50%

Thanks again, I'll keep the idea alive and take a look at those scripts...If I can come up with an install (and uninstallation) script that works nicely, I'll certainly put it in the tarball.

Reply to this


 kde 4.6

 by birdflesh on: Jan 27 2011
Score 50%

No rootactions option works for me since I upgraded to kde 4.6. After I enter my password I always get a Cannot execute command ' ''\''/usr/bin/rootactions-servicemenu.pl'\'.... This was probably caused by changes in kde's kdesu. kdesudo is not easily available in my distribution (arch linux), so I was hoping if you could take a look at this. Thanks!

Reply to this


 Re: kde 4.6

 by kubicle on: Jan 27 2011
Score 50%

I'll add that to my list of things to do.

Thanks for reporting.

Reply to this


 Re: kde 4.6

 by kubicle on: Jan 28 2011
Score 50%

Issue confirmed...didn't have much time to dig into it, but seems like an issue with nesting double/single quotes.

Example (with kdesu)
if I run
kdesu "'kate' 'foo'"
the resulting command shown in the kdesu dialog is:
-in kde sc 4.5.5: 'kate' 'foo'
-in kde sc 4.6.0: ''\"kate'\" '\".bashrc'\"'
(So we basically have escaped double quotes after each single quote, and then the whole thing wrapped inside single quotes...say what now?)

Theoretically, I might be able work around this within the script. But because it would require quite a bit of rewriting and testing, and (more importantly) because it would more than likely cause different breakage/problems somewhere else, I'd gladly wait a bit until either the issue gets fixed in kde/kdesu or I understand why 4.6 kdesu behaves as it does (if the change was intentional).

In the meantime, you could try using kdesudo (I seem to recall kdesudo is available in the AUR repositories for Arch), as it still works as expected (more accurately, as *I* expect)...although there was a similar issue with kdesudo quite some time ago (which was eventually fixed).

Reply to this


 Re: Re: kde 4.6

 by birdflesh on: Jan 28 2011
Score 50%

Actually I have an one(!) character fix for this. In rootactions-servicemenu.pl line 843, if you change "kdesu -d --" to "kdesu -d -c" everything works again. I believe that this commit http://websvn.kde.org/?view=revision&revision=1196645 is the one changing kdesu's previous behavior. I hope that it still works with previous kde versions (can't test it myself right now). Anyway thanks for taking your time on this and for all your fine work!

Reply to this


 Re: Re: Re: kde 4.6

 by kubicle on: Jan 28 2011
Score 50%


I'll upload the fix for testing ASAP (it shouldn't break anything).

Reply to this


 Re: Re: Re: kde 4.6

 by kubicle on: Jan 28 2011
Score 50%

Version 2.6.92 uploaded with the bytesize change.

Thanks again for the report and the detective work.

Reply to this


 Feedback 2.6.94 (2.7 beta3)

 by srog on: Jan 29 2011
Score 50%

Kubuntu 10.10, KDE 4.5.1

The desktop files are installed to the ~/.kde/share/kde4/services/ServiceMenus/. The perl script is not installed.

The first kdialog is not shown. From the commandline (servicemenuinstallation /home/rog131/.kde/share/apps/servicemenu-download/48411-rootactions_servicemenu_2.6.94.tar.gz) The error message:
"kdialog: Unknown option 'yes-label'."

Kubuntu 11.04 (alpha), KDE 4.6.0

The ruby script can't find the installKDE4.sh -> an KDE error notification. Ubuntu bug 667704.

Reply to this


 Re: Feedback 2.6.94 (2.7 beta3)

 by kubicle on: Jan 29 2011
Score 50%

1. Looks like changing button labels in kdialog is for kde sc 4.6> only...I'll work around that in the next version.

2. Hmm...works ok here on 4.6 Natty (with ruby installed). I'll try to investigate

Reply to this


 Re: Re: Feedback 2.6.94 (2.7 beta3)

 by srog on: Jan 29 2011
Score 50%

"2. Hmm...works ok here on 4.6 Natty (with ruby installed). I'll try to investigate"

The workaround (at here) to get the "Dolphin Download New Services" to work is so strange that i could have a borked installation.

I wouldn't use much time to investigate it.

It is possible that the workaround is working with the dropbox servicemenu but wouldn't work with the rootactions..

Reply to this


 Small problem

 by bugmenot1234 on: Mar 21 2011
Score 50%

First, I love this app. I've been using it for years now...ever since OpenSuse 10.1 and it works great.

I've been having a little problem with it lately though. Everything seems to work except "Start Krusader in root mode". Yeah, I forgot to mention I use Krusader exclusively.

Anyway, when I press this button it asks for the root password and when I provide it I get an error that says.

Cannot execute command ' '/usr/bin/krusader --left=file:///home/blah/blah/blah --right=file:///''.

I'm using OpenSuse 11.4 with KDE 4.6.00.

I know birdflesh described this and noted a change to a line of the script. I already checked the line and it fine.

$SUCOMMAND = "$KDEBINPATH"."kdesu -d -c"}

I believe the problem lies in the quotation marks here:

exec "$SUCOMMAND \"\'$EXECNAME\' do_root_konsole \'$APPNAME\' \'$WORKDIR\'\"";

Can anybody help with this?


Reply to this


 Disregard small problem post

 by bugmenot1234 on: Mar 22 2011
Score 50%

This has nothing to do with your great app. I'm taking this to krusader as it originates with them.

Sorry and thanks.

Reply to this


 Re: Disregard small problem post

 by kubicle on: Apr 12 2011
Score 50%

Looks like krusader was hit by the same bug/change in kdesu that affected this service menu.

As you figured out, the issue lies with krusader.

Reply to this


 Thank you for a GREAT utility

 by snowhog on: Apr 13 2011
Score 50%

I've been using your utility since I was made aware of it - several years ago - and it is one of the first things that gets installed after the installation of a new version of Kubuntu.

Thank you in spades. This is one of the most beneficial utilities I've seen. It should be included 'by default' in the *buntu distributions.

It takes less time to take the time to do it right the first time, than it does to fix it the second time.
Reply to this

goto page: prev   1  2  3  4  5  6  7  8  9  10  11  12 

Add commentBack


How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.


 Who we are
More about us
Frequently Asked Questions
Updates on identi.ca
Updates on Twitter
Content RSS   
News RSS   
Discussion RSS   
Events RSS   

Add Artwork
Public API
About KDE-Look.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Sponsor us
Report Abuse

Copyright 2001-2016 KDE-Look.org Team  
All rights reserved. KDE-Look.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.