-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Artwork
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login



Sponsoring


-
- Content .- Fans (2) .- Knowledge Base  . 

Aero AIO

   0.9.1  

Karamba

Score 77%
Aero AIO
zoom


Aero AIO
zoom


Aero AIO
zoom


Link:  http://
Minimum required   Qt 3.x
Downloads:  104901
Submitted:  May 25 2005
Updated:  May 17 2006

Description:

*** The configuration utility requires PyQT ***
Superkaramba >= 0.37 needed.

I wanted to make a theme that wouldn't take all my desktop and would allow me to see every information I could have with my previous Aero-G theme. Moreover I wanted it to be fully and easily configurable|customisable.
That's why I did Aero All In One!
You access to the piece of information you want in one click! Note that every page is unloaded when you load another one: cpu load is saved!

The configuration GUI allows you to install and load new plugins and to configure their options.

You can make new plugins, themes, and icon sets and put it in theme's directory or in "~/.aero_aio", they will be automatically detected!

Any comment/idea is welcome! Any piece of advice for my configuration utility (vocabulary or grammatical mistakes...) too.




Changelog:

Release 0.9.1:
- re-added option to disable animation
- added an option to show free space instead of used space in partitions plugin
- added options to change text font (developpers should update their plugins)
- some global improvements

Release 0.9.0:
- completely updated configuration dialog and configuration update engine
- updated plugin fonctions, developpers should update their plugins (nevertheless 0.8e plugins are still compatible)
- compatibility with superkaramba 0.39 verified
+ repaired auto-switching

Release 0.8e:
- fixed Network plugin wireless bug
- improved some plugins
- added butons to add external themes and icon sets from configuration dialog
- fixed compatibility issues with .aiz plugins when trying to install them with configuration gui.

Release 0.8d:
- fixed a bug in config dialog, updated Cpu and Clock plugins thanks to kovidgoyal
- updated GMail script thanks to arthur-kalm
- added wireless strengh monitor to network plugin thanks to aln

Release 0.8c:
- Made a .skz package for superkaramba 0.37, theme can be loaded zipped or unzipped!
- Added a plugin installation function in configuration gui: it automatically installs a plugin zipped in a ".aiz" zip archive in $HOME/.aero_aio directory.
- I will update my plugins in next release and add themes and icon sets installation functions.
NOTE to plugin developers: format of "theme" and "icon"parameters has changed, it's now the string of the full path to directory (ex: "/home/user/mythemes/aerog/"). It will be in the next plugin template. I'm writing a plugin developement guide.

Release 0.8b:
- added an option for calendar to start week on sunday
- possibility to load more than 8 plugins: scroll icons using your mouse's wheel
- added a new theme: "Blue Panel"
- made a new plugin: Amarok controler, download it separately
- made a complete plugin template
- made many improvements in code


Release 0.8a: Please report any bug!
- Re-made the engine completely! Now you can make your own plugins (with their configuration GUI page!) and put it in the Aero-AIO directory. I will publish a plugin template as soon as possible!
- Improved configuration GUI
Rem: next version (0.9) will be a .skz package

Release 0.7:
- !!! Improved configuration saving system : you will lose your previous configuration with this version !!!
- Updated "CPU and memory" page: now it has a graph
- Updated network page: you can display total transfered data and external IP address by clicking on the text under the graph
- Added GMail support to Mail page!
- Corrected Calendar wich was updating every seconds and taking 30% cpu, now it is updated every 20 minutes
- added a new theme: Glass
- added button animation

Release 0.6:
- Many bug fixes: Mem and CPU page, Mail page
- Enable shadow option (but because it isn't built in superkaramba you can change its color only by editing the bgcolor in the ".theme" file)
- Auto-detect new themes and icons sets: just put your themes in the "Themes" and "icon" directories.
- Improved Calendar: you can change displayed month by using the next and previous buttons (left click: next/prev month, middle click: next/prev year). Just click again on the calendar icon to
go back to current month.
- Improved System Infos page
- Improved a little network page

Release 0.5:
- *** fixed calendar bug ***
- some improvements: icon positions, icon selection, redrawWidget on click on icons
- tried to improve the code to avoid freezes when configuring Mail

Release 0.4:
- improved Clock page: if you click on the "digital clock" (in text) it switches between 12h/24h display
- the CpuMem page is now more "failsafe"
- you can name your partitions!
- fixed the bug wich appeared on the end of this month in Calendar, I hope this won't lead to a new bug in June...

Release 0.3:
- added Auto-Switch support: you can enable it through the configuration utility and can stop in one click on the icon in the bottom/left corner
- added an Aero-G style theme (see first screenshot)

Release 0.2:
- added an option to select the "temperature" file for the cpu & mem page
- added 2 icon sets: "default_small" and "nuvola"

Release 0.1:
- 8 pages
- 1 theme ("default")
- 2 icon sets ("default", "grey")




LicenseGPL
(Aero-AIO 0.9.1)
(Plugin template (0.9.0))
(Plugin developpement guide)
(Amarok plugin (.aiz))
Send to a friend
Subscribe
Other  Artwork  from AdrienV
Report inappropriate content



goto page: prev  ... 6  7  8  9  10  11  12  13  14  15  16  17  18  19  20  21 ...

-

 gmail not working

 
 by arthur-kalm on: Nov 17 2005
 
Score 50%

Hi,

I wanted to start off by saying that I just got this karamba and I _love_ it. Good job and definitely a great idea. Since this laptop has only a 12" screen there really isn't a lot of room on my desktop (1024 x 768). It was getting all cluttered with karambas and this one has replaced a lot of them! Thank you so much.

Now to business :P... the mail plugin with Gmail doesn't work. I did some investigation and discovered the problem. It seems that wget gets confused because my password for Gmail contains an "@" sign. Here is the command that you call from "scripts/getGMail.py" but done in the console:

arthur@ubuntu:~$ wget https://:@@mail.google.com/mail/feed/atom/
--00:17:19-- https://:*password*@%40mail.google.com/mail/feed/atom/
=> `index.html'
Resolving @mail.google.com... failed: Name or service not known.


Running the same URL in Firefox redirects me fine and displays the correct XML.

Maybe I should file a bug with wget? Or maybe is just a limitation wget has? If it is, maybe something else should be used since I think that I'm not the only one using "@" in their password. Any suggestions on what I (and others) can use as a workaround?

Thanks for such a great karamba!


Arthur Kalmenson
Reply to this

-

 Re: gmail not workin

 
 by arthur-kalm on: Nov 17 2005
 
Score 50%

Hmm it seems the the website filtered out my comment because it had greater and less than signs in it. Here is the correct command output:

arthur@ubuntu:~$ wget https://username:beginning_of_password@rest_of_password@mail.google.com/mail/feed/atom/
--00:17:19-- https://:*password*@rest_of_password%40mail.google.com/mail/feed/atom/
=> `index.html'
Resolving rest_of_password@mail.google.com... failed: Name or service not known.


Arthur Kalmenson
Reply to this

-

 Re: Re: gmail not wo

 
 by cherusker on: Nov 19 2005
 
Score 50%

@arthur: I think it's not (only) because of the "@ sign" in your password. Adrien already wrote that there was a mistake with wget and he wants to fix it in the next release.

@adrien: Can you tell us already what you did with wget to make the "error-message" go away (concerning gmail)? I really really can't wait any longer ;-)

Thank you so much for your efforts!!!


Reply to this

-

 Re: Re: Re: gmail no

 
 by arthur-kalm on: Nov 20 2005
 
Score 50%

Fixed it!

Here is the fix:

in $Aero-AIO_HOME/scripts/getGMail.py starting on line 11 you have the following:

def getGMailNum(login, password):
f = os.popen("wget -qO - https://" + login + ":" + password + "@mail.google.co
m/mail/feed/atom")
a = f.read()
...


Replace that with the following:

def getGMailNum(login, password):
password = re.sub("@", "%40", password)
f = os.popen("wget -qO - --no-check-certificate https://" + login + ":" + pass
word + "@mail.google.com/mail/feed/atom")
a = f.read()
f.close()
...

Note: REMEMBER TO INDENT everything under getGMailNum to the same indentation level as the rest of the things in the function because I can't make indentations in this forum.

As you can see, I changed "@" into a "%40" so that wget doesn't get confused. Furthermore, during my testing with wget I found that there were some problems with SSL so you need to use the "--no-check-certificate" parameter.

This works for me. Enjoy! :)


Arthur Kalmenson
Reply to this

-

 Re: Re: Re: Re: gmai

 
 by AdrienV on: Dec 15 2005
 
Score 50%

Why not using password.replace('@','%40') rather than re.sub('@','%40', password)?
I have put it in 0.8d.


Reply to this

-

 small bug

 
 by kovidgoyal on: Nov 27 2005
 
Score 50%

For a machine with multiple processors and/or hyperthreading your cpu speed detection code doesn't work, you need to change grep MHz to grep -m1 MHz

Otherwise an excellent theme


Kovid
Reply to this

-

 mods and kmail plug

 
 by kovidgoyal on: Nov 27 2005
 
Score 50%

Hi,

I modified the clock theme to look a little neater. See http://kde-look.org/content/show.php?content=31841

If you like it, maybe you could include it in your next release

Also, I have written a kmail mail notification plugin
http://kde-look.org/content/show.php?content=31838


Reply to this

-

 3rd party plugins

 
 by kovidgoyal on: Nov 28 2005
 
Score 50%

Hi,

I really like Aero AIO and have been writing several plugins for it. I think you need to incorporate a mechanism to load 3rd part plugins once Aero AIO is distributed as a .skz

For e.g. you could have it load plugins from an external directory like ~/.aero-aio/plugins/pluginname

Since the external diretory is fixed, the plugins would know to look for their media files in it

Just a suggestion, if there is already a mechanism in place, could you tell me about it?


Reply to this

-

 Re: 3rd party plugin

 
 by AdrienV on: Dec 5 2005
 
Score 50%

That's what I'm currently working on. It will take some time but I don't have many time! So be patient. Currently the mechanism adds new plugins in the archive. But doing so means that I must build an update system or users will lose their plugins when downloading new versions...
But I think I will change this to load plugins out of .skz archive.


Reply to this

-

 Re: Re: 3rd party plugin

 
 by kovidgoyal on: Dec 6 2005
 
Score 50%

Thanks for replying. No hurry...I also think that loading plugins from an external directory would be better. If you need help, I'll be happy to volunteer.


Reply to this

-
.

 Re: Re: Re: 3rd part

 
 by AdrienV on: Dec 15 2005
 
Score 50%

In Aero AIO 0.8c new plugins can be installed in $HOME/.aero_aio/ where they will be automatically detected.
Thank you.


Reply to this

-

 Cannot Configure

 
 by EclipseAgent on: Nov 30 2005
 
Score 50%

I get an error: You need PyQT to configure this theme. But I have kdebindings3-python 3.5.0-7 installed. What can be causing this? How can I fix it? Should I remove kdebindings3-python then try to reload it? (well, I did and still no go).


Reply to this

-

 Re: Cannot Configure

 
 by kovidgoyal on: Dec 3 2005
 
Score 50%

PyQT refers to the python QT bindings. PyKDE are the python KDE bindings


Reply to this

-
.

 Re: Re: Cannot Confi

 
 by linkiln on: Dec 3 2005
 
Score 50%

I to have this error. I'he install a sip PyQt i PyKDE... and configuration still don't work ?? What I must do to config work ??


Reply to this

-

 Re: Re: Re: Cannot Confi

 
 by kovidgoyal on: Dec 6 2005
 
Score 50%

Well you get the PyQT needed error if import the QT Python classes fails. i.e. the python interpreter can't locate the necessary modules. You can test this by typing python at a command prompt and then at the python prompt
from qt import *
If this fails you know that your installation of pyqt is buggy


Reply to this

-

 Problems for config.

 
 by tbd on: Dec 8 2005
 
Score 50%
tbdtbd
Univ. of Las Palmas de G.C.
-
T. Bautista 0

Univ. of Las Palmas de G.C.
Spain, Vega de San Mateo
Last visit May 14 2014
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

Hi,

I wished to use this piecs of jewel but without success. I presumed it was a problem with my PyQT installation, but the fact is that I have no idea of what it is really happening. I'm using KDE 3.5 on a Debian sid with:

python2.3-qt3 3.15-4 Qt3 bindings for Python 2.3

pyqt-tools 3.15-4 pyuic and pylupdate for Qt3

I don't know if these are the needed ones or other ones are also required, but the issue is that it does not allow me to configure anything, and when trying to load the kmail plugin (and now I don't really know if when not too) usually gives this error on the terminal:

arguments do not match

No such application: 'displayPath'

Any hints would be greatly appreciated.

Greetings.


Reply to this

-

 Re: Problems for config.

 
 by kovidgoyal on: Dec 8 2005
 
Score 50%

Two suggestions:
1) I've only ever tested the KMail plugin with Python 2.4 and the latest PyKDE snapshot from http://www.riverbankcomputing.co.uk/pykde/index.php
To get it to compile with KDE 3.5 you may need to read
http://www.mail-archive.com/pykde%40mats.imk.fraunhofer.de/msg05768.html

2) Delete your installation of Aero-AIO and redownload and re-install everything...there was a bug in the KMail config script that I fixed a couple of days ago


Reply to this

-

 Re: Problems for config.

 
 by kovidgoyal on: Dec 8 2005
 
Score 50%

Two suggestions:
1) I've only ever tested the KMail plugin with Python 2.4 and the latest PyKDE snapshot from http://www.riverbankcomputing.co.uk/pykde/index.php
To get it to compile with KDE 3.5 you may need to read
http://www.mail-archive.com/pykde%40mats.imk.fraunhofer.de/msg05768.html

2) Delete your installation of Aero-AIO and redownload and re-install everything...there was a bug in the KMail config script that I fixed a couple of days ago


Reply to this

goto page: prev  ... 6  7  8  9  10  11  12  13  14  15  16  17  18  19  20  21 ...

Add commentBack






-

-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore




 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Artwork
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
News RSS   
Discussion RSS   
Events RSS   

Participate
Groups
Forum
Add Artwork
Public API
About KDE-Look.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2001-2014 KDE-Look.org Team  
All rights reserved. KDE-Look.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.