-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Artwork
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login



Sponsoring


-
- Content .- Fans (7) .- Knowledge Base  . 

kde-plasma-mail-checker

   1.15.68  

Plasmoid Script

Score 65%
kde-plasma-mail-checker
zoom


kde-plasma-mail-checker
zoom


kde-plasma-mail-checker
zoom


Minimum required   KDE 4.x
Downloads:  2987
Submitted:  Mar 23 2011
Updated:  Apr 6 2014

Description:

Plasmoid should periodic check for new messages in configured accounts.
Supported protocols: POP3/POP3S/IMAP4/IMAP4S + IMAP4_IDLE.
Passwords for accounts stored in KWallet.
Plasmoid use KDE-notification for events about new mail.
Support Akonadi (mimeType : "message/rfc822") resources monitoring
(getting new mail).
Support preview (integrated mail viewer) for non-Akonadi accounts
and Quick Answer & Forward Mail (need to install the package same
python-mailer).
Support command line in notification.
See for: EXAMPLES.

https://github.com/F1ash/kde-plasma-mail-checker




Changelog:

https://github.com/F1ash/kde-plasma-mail-checker/blob/simple/Changelog

# TODO :
complete "ru"-dictionary for new version;




LicenseGPL
(kde-plasma-mail-checker)
Send to a friend
Subscribe
Other  Artwork  from F1ash
Report inappropriate content



goto page: prev   1  2  3  4  5 

-

 IMAP error

 
 by shote on: May 8 2013
 
Score 50%

Hi,
I get the following error on some servers with IMAP:
argument must be 9-item sequence, not None
Unfortunately cannot test with POP3 there as they don't provide POP3 login.


Reply to this

-

 Re: IMAP error

 
 by F1ash on: May 8 2013
 
Score 50%

Pls, find in ~/.xsession-errors the Traceback associated with this error. This will help me to quickly fix an error.


Reply to this

-

 Re: Re: IMAP error

 
 by shote on: May 8 2013
 
Score 50%

unfortunately there is no traceback
This is the only log I got:

2013.05.08_15:16:20 : argument must be 9-item sequence, not None IMAP4
2013.05.08_15:16:21 : argument must be 9-item sequence, not None IMAP4
2013.05.08_15:16:21 : argument must be 9-item sequence, not None IMAP4


Reply to this

-

 Re: Re: Re: IMAP error

 
 by F1ash on: May 8 2013
 
Score 50%

I`m make some changes for identify an error. Watch out for logs.


Reply to this

-
.

 Re: Re: Re: Re: IMAP error

 
 by akwala on: Mar 14 2014
 
Score 50%

I get this error in v. 1.15.66 on Ubuntu 13.10. See: https://github.com/F1ash/kde-plasma-mail-checker/issues/10


--aslamK
Reply to this

-

 Re: Re: Re: Re: Re: IMAP error

 
 by F1ash on: Mar 15 2014
 
Score 50%

try this version:
<a href="http://fbe.am/rxF">DOWNLOAD</a>


Reply to this

-

 Re: IMAP error

 
 by akwala on: Mar 17 2014
 
Score 50%

Same issue with the new version you asked me to try...

argument must be 9-item sequence, not None argument must be 9-item sequence, not None argument must be 9-item sequence, not None Can`t connect to server on Account...


--aslamK

-

 Re: Re: IMAP error

 
 by F1ash on: Mar 24 2014
 
Score 50%

you must be sure that you have installed the plasmoid correctly, that code replaced by a new.
Try this:
http://fbe.am/rKf


Reply to this

-

 Re: Re: Re: IMAP error

 
 by akwala on: Apr 1 2014
 
Score 50%

Uninstalled the plasmoid, then installed 1.15.67. Works fine now, no error.

Thanks.


--aslamK
Reply to this

-

 Re: Re: Re: Re: IMAP error

 
 by akwala on: Apr 1 2014
 
Score 50%

Welll... the same error started appearing again but for a different account than before:

argument must be 9-item sequence, not None argument must be 9-item sequence, not None argument must be 9-item sequence, not None Can`t connect to server on Account...


--aslamK
Reply to this

-

 Re: Re: Re: Re: Re: IMAP error

 
 by F1ash on: Apr 3 2014
 
Score 50%

some elusive bug :)
try v1.15.68


Reply to this

-

 Re: Re: Re: Re: Re: Re: IMAP error

 
 by akwala on: Apr 4 2014
 
Score 50%

No change w/ 1.15.68 :(

Same error as before for the same accounts.


--aslamK

-

 Re: Re: Re: Re: Re: Re: IMAP error

 
 by F1ash on: Apr 5 2014
 
Score 50%

it's a very, very strange... I can to see plasmoid log ?



-

 Re: Re: Re: Re: Re: IMAP error

 
 by F1ash on: Apr 4 2014
 
Score 50%

I corrected another probable error, reinstall , pls.


Reply to this

-

 Re: IMAP error

 
 by akwala on: Apr 5 2014
 
Score 50%

The version is still 1.15.68 -- tested download from here as well as Github.

The same error persists.


--aslamK

-

 Setting the time between email checks.

 
 by akwala on: Apr 1 2014
 
Score 50%

I don't see a setting to specify how often an account should be checked for new email. It's not among the settings for an account (where it should ideally be) nor on the global Settings tab.

Is this planned for the future?


--aslamK
Reply to this

-

 Re: Setting the time between email checks.

 
 by F1ash on: Apr 1 2014
 
Score 50%

This is the global setting:
http://img.flashtux.org/img13351711bb1bx89d301b6.png


Reply to this

-

 Re: Re: Setting the time between email checks.

 
 by akwala on: Apr 2 2014
 
Score 50%

Thanks.

"Timeout" is misleading in this case. A timeout is usually a waiting period after which a process gives up on an action that does not complete.

The setting in question is the time period between email checks (or connection attempts).

If "Autoexit of connect" is the time to wait for a connection attempt to succeed before considering it a failed attempt, then this setting would be better described as a timeout.


--aslamK
Reply to this

-

 UI annoyance when adding/editing accounts

 
 by akwala on: Apr 1 2014
 
Score 50%

After adding/editing an account, clicking the OK or Cancel buttons closes the config window. To do further configuration (e.g., add/edit another account or change global settings) one has to reopen the config window, which gets tiresome. Clicking the OK/Cancel button should return the window to the top-level state of the Accounts tab, showing the list of accounts


--aslamK
Reply to this

-

 Re: UI annoyance when adding/editing accounts

 
 by F1ash on: Apr 1 2014
 
Score 50%

Use colorized buttons fot it:
http://img.flashtux.org/img13351711bc96xcf9b9039.png


Reply to this

-

 Re: Re: UI annoyance when adding/editing accounts

 
 by akwala on: Apr 2 2014
 
Score 50%

Thanks.


--aslamK
Reply to this

-

 Cannot concatenate 'str' and 'list' objects

 
 by bmonnier39 on: Apr 5 2014
 
Score 50%

Hello,

I just installed KDE-plasma-mail-checker this afternoon.

I get this message :

cannot concatenate 'str' and 'list' objects cannot concatenate 'str' and 'list' objects cannot concatenate 'str' and 'list' objects
Can`t connect to server on Account : XXXXXXXXXX@gmail.com

Please help !


Reply to this

-

 Re: Cannot concatenate 'str' and 'list' objects

 
 by F1ash on: Apr 5 2014
 
Score 50%

Pls, paste the log
Error log file: $HOME/.xsession-errors
Debug log file: /tmp/outMailChecker_%Y_%m_%d_%H:%S.log
because it is a difficult to search the bugs using unmarked messages.


Reply to this

-

 Re: Re: Cannot concatenate 'str' and 'list' object

 
 by bmonnier39 on: Apr 6 2014
 
Score 50%

Hello

The Error log file ($Home/.xsession-errors) shows :
Script for cjkv started at run_im.
Script for default started at run_im.

The Debug log file (file:///tmp/outMailChecker_2014_04_06_07:06:20.log) is empty.

Thanks for your help


Reply to this

-

 Re: Re: Cannot concatenate 'str' and 'list' object

 
 by bmonnier39 on: Apr 6 2014
 
Score 50%

Sorry, I forgot to precise :
- I run Kubuntu 13.10 X86-64, KDE 4.12.2, and the version of M@ilChecker is 1.15.63


Reply to this

-

 Re: Re: Re: Cannot concatenate 'str' and 'list' ob

 
 by F1ash on: Apr 6 2014
 
Score 50%

Update to new 1.15.68, pls.
And: there are exist (by default) 3 or 5 logs of last sessions, and if mail-checker is running, then current log is empty, because logging file is not closed.


Reply to this

-

 Re: Re: Re: Re: Cannot concatenate 'str' and 'list

 
 by bmonnier39 on: Apr 6 2014
 
Score 50%

Hello,

1- I followed your instructions, and I've upgraded to last version 1.15.68 -- but I get the same message

2- You're right, I have three debug logs :

a- file:///tmp/outMailChecker_2014_04_06_07:06:20.log :

2014.04.06_07:06:29 : processInit
2014.04.06_07:06:29 : True Module PyKDE4.akonadi is available.
2014.04.06_07:06:29 : _refresh
2014.04.06_07:06:29 : time for wait thread : 120
2014.04.06_07:13:10 : Module PyKDE4.akonadi is
available.
2014.04.06_07:13:15 : idleingStoppedEvent
2014.04.06_07:13:17 : processInit
2014.04.06_07:13:17 : True Module PyKDE4.akonadi is available.
2014.04.06_07:13:17 : _refresh
2014.04.06_07:13:17 : time for wait thread : 120
2014.04.06_07:16:26 : Module PyKDE4.akonadi is
available.
2014.04.06_07:16:41 : idleingStoppedEvent
2014.04.06_07:26:44 : eventCloseMethod
2014.04.06_07:26:44 : wallet closed
2014.04.06_07:26:44 : MailChecker destroyed manually.

b- file:///tmp/outMailChecker_2014_04_06_07:26:59.log :

2014.04.06_07:27:01 : processInit
2014.04.06_07:27:01 : True Module PyKDE4.akonadi is available.
2014.04.06_07:27:01 : _refresh
2014.04.06_07:27:01 : time for wait thread : 120
2014.04.06_07:27:16 : eventCloseMethod
2014.04.06_07:27:16 : wallet closed
2014.04.06_07:27:16 : MailChecker destroyed manually.

c- file:///tmp/outMailChecker_2014_04_06_11:20:21.log

2014.04.06_11:20:23 : processInit
2014.04.06_11:20:23 : True Module PyKDE4.akonadi is available.
2014.04.06_11:20:23 : _refresh
2014.04.06_11:20:23 : time for wait thread : 120
2014.04.06_11:21:31 : eventCloseMethod
2014.04.06_11:21:31 : wallet closed
2014.04.06_11:21:31 : MailChecker destroyed manually.

I hope you will resolve this problem...

Thanking you in advance.


Reply to this

-

 Re: Re: Re: Re: Re: Cannot concatenate 'str' and '

 
 by F1ash on: Apr 6 2014
 
Score 50%

If you have the plasmoid installed and in the system (using apt-get or yum or same) and to the user $HOME, it will use the code from the system installation.
I did debug-log is now more informative. Make sure you are using the latest version.


Reply to this

-

 Re: Re: Re: Re: Re: Re: Cannot concatenate 'str' a

 
 by bmonnier39 on: Apr 6 2014
 
Score 50%

I'm sorry, Still not working.
I'm using the latest version. I desinstalled it and installed again (using the "Panel Tool Box -- Add Widgets -- Get New Widgets -- Download". I'm using the latest version. But I get the same message.



-

 Re: Re: Re: Re: Re: Re: Cannot concatenate 'str' a

 
 by F1ash on: Apr 6 2014
 
Score 50%

and show me the new debug-log, please...



-

 Re: Re: Re: Re: Re: Cannot concatenate 'str' and '

 
 by F1ash on: Apr 6 2014
 
Score 50%

where you installed version 1.15.63?
and how do you install it?


Reply to this

-

 Re: Re: Re: Re: Re: Re: Cannot concatenate 'str' a

 
 by bmonnier39 on: Apr 6 2014
 
Score 50%

I have not installed myself the previous version, it came along the distro Kubuntu I use, with the other widgets.

And I have no idea where this version 1.15.63 could be ! I tried to find it using Synaptic and Muon, but I could'nt find any "plasma mail checker" or "mail checker" installed... I'm confused.



-

 Re: Re: Re: Re: Re: Re: Cannot concatenate 'str' a

 
 by bmonnier39 on: Apr 6 2014
 
Score 50%

The last debug log is :
2014.04.06_18:40:10 : processInit
2014.04.06_18:40:10 : True Module PyKDE4.akonadi is available.
2014.04.06_18:40:10 : _refresh
2014.04.06_18:40:10 : time for wait thread : 120
2014.04.06_18:41:19 : Module PyKDE4.akonadi is
available.
2014.04.06_18:41:59 : idleingStoppedEvent
2014.04.06_18:42:02 : processInit
2014.04.06_18:42:02 : True Module PyKDE4.akonadi is available.
2014.04.06_18:42:02 : _refresh
2014.04.06_18:42:02 : time for wait thread : 120
2014.04.06_18:42:09 : eventCloseMethod
2014.04.06_18:42:09 : wallet closed
2014.04.06_18:42:09 : MailChecker destroyed manually.



-

 Re: Re: Re: Re: Re: Re: Cannot concatenate 'str' a

 
 by F1ash on: Apr 6 2014
 
Score 50%

try :
apt-get remove kde-plasma-mail-checker

and it is strange that in the log no reports of failed connections to servers. they must be.



-

 For BUGs commiters

 
 by F1ash on: Apr 8 2014
 
Score 50%

For BUGs commiters: please, specify the type of connection (pop3, imap / idle, ssl / none), so it was easier to keep track of.


Reply to this

goto page: prev   1  2  3  4  5 

Add commentBack






-

-
Do you like or dislike Ubuntu Unity?
 Yes, unity is alien technology!
 It is less confusing than Gnome 3 default, shell.
 Granny thinks it is much more usable than Gnome 2
 Canonical is embarrasing itself with this split project
 Gnome 3 default shell is much better
 I dislike Unity, Gnome 3 default shell is alien technology!
 None of the above, I like the 2Gb for free and Apple alike behavior. Will post a comment instead

resultmore




 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Artwork
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
News RSS   
Discussion RSS   
Events RSS   

Participate
Groups
Forum
Add Artwork
Public API
About KDE-Look.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2001-2014 KDE-Look.org Team  
All rights reserved. KDE-Look.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.