-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Artwork
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login



Sponsoring


-
- Content .- Fans (8) .- Knowledge Base  . 

ALSA Volume Control plasmoid

   0.51.2  

Plasmoid Script

Score 69%
ALSA Volume Control plasmoid
zoom


ALSA Volume Control plasmoid
zoom


ALSA Volume Control plasmoid
zoom


other:  Link
Minimum required   KDE 4.x
Downloads:  2160
Submitted:  Feb 20 2011
Updated:  Apr 1 2014

Description:

Plasmoid controls alsa devices by mouse. You can add plasmoid to panel (both vertical && horisontal) or to workspace.
You must install python-alsaaudio or similar in your distributive.




Changelog:

v.0.25
* fixed audiodevice detecting error;
* added detecting multiple audiodevices in system;
* added color managment of font and panel sliders with support opacity;
* added device rescan without restart plasmoid;
* added plasmatooltip with representation
device volume in panel;

v.0.27
* added Rescan button to Panel Devices Settings;
* added color control for slider handlers;

v.0.28
* fixed cardindex detection;

v.0.30
* improved stop control of tracking thread;
* added detect system color of text for first start;

v.0.35
* changed method of thread complete;

v.036
* text is replaced by icons in Common Device Panel;

v.0.37
* fixed warning in import module errors;

v.0.41.2 :
* added restore of device volume;
* added retrieve restored volume parameters;
* fixed slider`s mouseRelease & doubleClick events for common events;
* fixed the freez at plasmoid's init;
* some fixes & improvements;

v.0.42.2 :
* some fixes & improvements;

v.0.42.3 :
* fixed initiate;
* improve initiate;

v.0.43.5 :
* fixed the applet init at case without available audio devices;
* some fixes && improvements;

v.0.50.0 :
* fixed changing a color of horizontal slider's handler;
* refactoring;
* added slider's size Settings;
* added displaying a changes of slider's color & size into Settings;

v.0.51.0 :
* added sensitivity for sliders;

v.0.51.1 :
* reimplemented the retrieve of restored volume parameters;
* some fixes for disconnect SLOTs at close;

v.0.51.2 :
* added the restriction of notification;
* reimplemented tooltip;




LicenseGPL
(kde-plasma-alsa-volume)
Send to a friend
Subscribe
Other  Artwork  from F1ash
Report inappropriate content



goto page:  1  2  3 

-

 Does not work

 
 by Wonko on: Feb 21 2011
 
Score 50%

I only get a red icon with an white cross in it. With the mouse over it, I get a message (translated to English): Mini-progam could not be loaded. The python-script-driver for plasmaVolume cound not be initialized.

KDE 4.6.0, Gentoo Linux


Reply to this

-
.

 Re: Does not work

 
 by F1ash on: Feb 21 2011
 
Score 50%

Please, install :
kdebase-workspace-python-applet
python-alsaaudio

I`m tested in Fedora 14.


Reply to this

-
.

 Re: Does not work

 
 by thomassisson on: Apr 28 2013
 
Score 50%
thomassissonthomassisson
Indiana University-P urdue University Indianapolis
Home
-
Thomas Sisson 0

Indiana University-Purdue University Indianapolis
United States of America, Indianapolis
Last visit Dec 26 2013
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

I received this message (below) when try to install one of the suggested packages. Do you know if it has been renamed? I was able to install the other python package.

"Unable to locate package kdebase-workspace-python-applet"


Reply to this

-
.

 Re: Does not work

 
 by thomassisson on: Apr 28 2013
 
Score 50%
thomassissonthomassisson
Indiana University-P urdue University Indianapolis
Home
-
Thomas Sisson 0

Indiana University-Purdue University Indianapolis
United States of America, Indianapolis
Last visit Dec 26 2013
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

I did some searching and it appears that for Kubuntu the package is plasma-scriptengine-python instead of kdebase-workspace-python-applet. I already had plasma-scriptengine-python, so I'm still not sure what the issue is.

I was really hoping for a volume control that does not default to the maximum of 100%. Pulse Audio Volume Control allows the volume to go up to 153%, but does not have a widget, gadget, applet for the panel.


Reply to this

-

 Re: Re: Does not work

 
 by F1ash on: Apr 28 2013
 
Score 50%

This package "kdebase-workspace-python-applet" for Fedora14. Python-alsaaudio should installed for work.


Reply to this

-

 Re: Does not work

 
 by F1ash on: Feb 21 2011
 
Score 50%

kdebase-4.5.5-1.fc14
python-2.7-8.fc14
Plasmoid shouldn`t work in Python3.


Reply to this

-

 Re: Does not work

 
 by Wonko on: Feb 21 2011
 
Score 50%

I installed dev-python/pyalsaaudio, that alone does not help. And I don't seem to have a package like kdebase-workspace-python-applet in Gentoo.

It's no problem, the normal volume applet is okay for me, I just wanted to try yours when I saw the announcement on KDE-Look.


Reply to this

-
.

 Re: Re: Does not work

 
 by F1ash on: Mar 3 2011
 
Score 50%

Hi, try new version ;) . I`m make some fixes.


Reply to this

-

 Re: Does not work

 
 by Wonko on: Mar 4 2011
 
Score 50%

Yes, it it working now. I'll think I'll keep using it, it's easier now to control both PCM and Front without having to open the KMix window.

I had one strange problem though: Suddenly, many of my runing plasmoids disappeared, and a folder view plasmoid I have running on one desktop suddenly appeared on several desktops. Weird, but at least things were okay when I logged in again.

But it may also be the fault of the 'Mixeroid' plasmaoid which I added to the desktop just before I tried yours.

Or it was a random bug that has nothing to do with both.


Reply to this

-

 Re: Re: Does not work

 
 by F1ash on: Mar 4 2011
 
Score 50%

May be it`s random; i`m not have this problem. Report me if this occurrence should repeated.


Reply to this

-

 mixer

 
 by mentalrey on: Mar 5 2011
 
Score 50%

hi,
if i get you separate graphic pieces,
do you think is possible to obtain a
panel/plasmoid like this?

http://www.mentalrey.it/icon_set/alsa_mixer.jpg
http://www.mentalrey.it/icon_set/click.png


Reply to this

-

 Re: mixer

 
 by F1ash on: Mar 5 2011
 
Score 50%

I`m consulted on this issue.
Necessary to make these images in SVG.
I do not know how to do it. If you do this, then I can try.


Reply to this

-

 Error in Initialization script

 
 by tittiatcoke on: Mar 5 2011
 
Score 50%

Hi,

I really would like to use your applet, but I can't seem to get it working.

When adding the plasmoid, I get the following error :


Traceback (most recent call last):
File "/usr/share/kde4/apps/plasma_scriptengine_python/pyappletscript.py", line 75, in init
self.pyapplet.init()
File "/home/hq000006/.kde4/share/apps/plasma/plasmoids/plasmaVolume/contents/code/main.py", line 130, in init
self.initContent()
File "/home/hq000006/.kde4/share/apps/plasma/plasmoids/plasmaVolume/contents/code/main.py", line 194, in initContent
for audioDevice in alsaaudio.mixers(card) :
alsaaudio.ALSAAudioError: No such file or directory

I have python-alsaaudio installed, but am running openSUSE. Do you know what I am missing in this case ?

Thanks

Great work !!


Reply to this

-

 Re: Error in Initialization script

 
 by F1ash on: Mar 5 2011
 
Score 50%

You can try execute manually in console :
$ python
....
>>> import alsaaudio
>>> alsaaudio.cards()
For example:
[u'Intel', u'psci', ...]

if list is empty then python-alsaaudio not detected your audiodevice.


Reply to this

-

 Re: Error in Initialization script

 
 by F1ash on: Mar 5 2011
 
Score 50%

You can try execute manually in console :
$ python
....
>>> import alsaaudio
>>> alsaaudio.cards()
For example:
[u'Intel', u'psci', ...]

if list is empty then python-alsaaudio not detected your audiodevice.


Reply to this

-

 Re: Re: Error in Initialization script

 
 by tittiatcoke on: Mar 5 2011
 
Score 50%

The output is


hq000006@HQVMT4XX20:~> python
Python 2.7 (r27:82500, Aug 07 2010, 16:54:59) [GCC] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import alsaaudio
>>> alsaaudio.cards()
[u'Intel', u'ThinkPadEC']
>>>


So I guess that my soundcard is recognized. Anything else I can try ?

thanks for your help.


Reply to this

-

  Re: Error in Initialization script

 
 by F1ash on: Mar 5 2011
 
Score 50%

Execute, please:
>>> for i in xrange(100) :
... try :
... print alsaaudio.mixers(i)
... except alsaaudio.ALSAAudioError :
... print i, ' error'
... continue


script : http://fpaste.org/fLrP/

may be error in detecting cardindex
I must sure in it...


Reply to this

-

  Re: Error in Initialization script

 
 by F1ash on: Mar 5 2011
 
Score 50%

I made cardindex detection by another method. Please, try to install now.


Reply to this

-

 Re: Re: Error in Initialization script

 
 by tittiatcoke on: Mar 7 2011
 
Score 50%

Sorry for not coming back to you earlier, but the change indeed worked. The plasmoid is now detecting the device and I can control the volume.

Somehow I do not see any text on the plasmoid, but this could be caused by my plasma desktop theme.

Thanks for solving the issue.


Reply to this

-
.

 not working in Kubuntu 10.10

 
 by bartman2589 on: Mar 6 2011
 
Score 50%

I was hoping to use this plasmoid to be able to easily access the volume sliders on a couple different channels of my onboard sound since the 'Master' channel doesn't work properly on my system (doesn't do anything actually), and the PCM slider only seems to affect digital input (like from playing a .wav or .mp3 file or watching a video) it doesn't have any effect on the volume of the other channels (as one might reasonably expect), as a result when I turn down the volume of things using my keyboard volume controls things like my CD channel (to which I have my tv tuner card connected) are unaffected and continue to play at whatever volume was previously set.

However I am having a few problems using this plasmoid:

1. when I click on the plasmoid and the window opens with the sliders for the volume controls I can't see any text at all except what's on the mute buttons and the rescan button. I can see the sliders and the scrollbar but no text at all other than what I mentioned.

2. when I open the settings page I don't see any text at all, just various icons.

3. when I try to close the plasmoid (when it's running on my taskbar) it crashes my plasma desktop. Only thing that still responds is the mouse/keyboard and my dropdown terminal (I use Tilda (a gnome app) because I like the fact that it can be set to 100% width, unlike yakuake).

I'm using the Oxygen theme that comes with Kubuntu/KDE 4.5.5 from the Kubuntu Updates PPA (black plasmoid backgrounds with a glossy look to them).

here is the output I get when I run it using plasmoidviewer:

Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
plasmoidviewer(2492)/kdecore (services) KServiceFactory::findServiceByDesktopPath: "" not found
plasmoidviewer(2492)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0)
plasmoidviewer(2492)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0)

I would appreciate any help you can provide in getting this plasmoid working.

Thank you,
bartman2589


Reply to this

-

 Re: not working in Kubuntu 10.10

 
 by bartman2589 on: Mar 6 2011
 
Score 50%

One minor correction, when I say I don't see any text on the setup screen for the plasmoid I meant to say I don't see any on the Colors page of it, only the buttons that open up the color choosers, no text at all to tell me what each button is used to choose the color for.


Reply to this

-

 Re: Re: not working in Kubuntu 10.10

 
 by bartman2589 on: Mar 6 2011
 
Score 50%

also I wanted to tell you there appears to be an error in the way it's packaged, when I use the install instruction provided (after I rename the zip file to match the instructions), I get an error message basically saying that the metadata.desktop file is not present. I was able to work around this by repackaging it by extracting everything to a folder and then adding the contents of the folder (not the folder itself) to a new zip file.


Reply to this

-

 Re: Re: not working in Kubuntu 10.10

 
 by F1ash on: Mar 6 2011
 
Score 50%

One minor correction, when I say I don't see any text on the setup screen for the plasmoid I meant to say I don't see any on the Colors page of it, only the buttons that open up the color choosers, no text at all to tell me what each button is used to choose the color for.
----
default Settings of colour is black and opacity. Therefore you do not see them. Set it manual.


Reply to this

-

 Re: Re: not working in Kubuntu 10.10

 
 by F1ash on: Mar 6 2011
 
Score 50%

"answer below" == "answer above"

One minor correction, when I say I don't see any text on the setup screen for the plasmoid I meant to say I don't see any on the Colors page of it, only the buttons that open up the color choosers, no text at all to tell me what each button is used to choose the color for.
----
default Settings of colour is black and opacity. Therefore you do not see them. Set it manual.


Reply to this

-

 Re: Re: not working in Kubuntu 10.10

 
 by F1ash on: Mar 6 2011
 
Score 50%

"answer below" == "answer above"

One minor correction, when I say I don't see any text on the setup screen for the plasmoid I meant to say I don't see any on the Colors page of it, only the buttons that open up the color choosers, no text at all to tell me what each button is used to choose the color for.
----
default Settings of colour is black and opacity. Therefore you do not see them. Set it manual.


Reply to this

-

 Re: Re: Re: not working in Kubuntu 10.10

 
 by bartman2589 on: Mar 7 2011
 
Score 50%

Ok, but why don't you make it so that the text in the color settings panels show up in black like all the other text in the settings panel so that people can know what each color button is for. You could even use a small box to display a sample of the color currently selected for that item that way people aren't just presented with a screen with color buttons, they might actually be able to know what each color picker button is for before they choose a color instead of having to guess. Also, I tried setting all of them to white in the hopes that it would make a difference but on my system it didn't even apply the color changes to the plasmoid, only to the text on the color settings tab that I previously was unable to see, and just like with when I tried to remove the plasmoid from my taskbar when I try to close the settings window my entire desktop freezes, I have to restart my computer in order to get things working again. It doesn't do me any good to change the colors unless this problem is fixed so that my desktop doesn't lockup. Any ideas? I've already done everything you've told everyone above to do in terms of installing certain packages.


Reply to this

-

 Re: not working in Kubuntu 10.10

 
 by F1ash on: Mar 7 2011
 
Score 50%

For example :
http://img.flashtux.org/img132dbe31e2e0x9f249c0d.png

Color settings should look like.
So I think that you have occurred incorrect installation of the plasmoid.
I set up a plasmoid in a standard way:
Panel Tool Box -- Add Widgets -- Get New Widgets -- (Download... or Instal...).
Manual installation is successful too.

https://github.com/F1ash/plasmaVolume
This link is to validate the contents of the zip.

About default colors: I'll try to fix it quickly.


Reply to this

-

 Re: Re: Re: Re: not working in Kubuntu 10.10

 
 by F1ash on: Mar 7 2011
 
Score 50%

About freez after Settings close :
at this point is expected to stop the thread of tracking the changing status of audiodevices. Just one of your previous posts to me, it is clear that stopping the thread does not occur. I'm sure know how to do this.

For quick correction : uncomment line 161 in
def stopWaitingVolumeChange(self) in file
~/.kde/share/apps/plasma/plasmoids/plasmaVolume/contents/code/main.py

I'll correct it in the next version.


Reply to this

-

 Re: Re: Re: Re: not working in Kubuntu 10.10

 
 by F1ash on: Mar 7 2011
 
Score 50%

I made correction. Try new version, please.


Reply to this

-

 ÐÑивеÑ.

 
 by madegirah on: Mar 6 2011
 
Score 50%

Было бы круто добавить в плазмоид управление громкостью звука при помощи поворота колёсика мыши при наведении курсора на пламоид на панели, как это сделано в дефолтном kmix


Reply to this

-

 Re: ÐÑивеÑ.

 
 by bartman2589 on: Mar 6 2011
 
Score 50%

I'm guessing you missed the part below the emote icons that says "All text must be in English."


Reply to this

-

 Re: ÐÑивеÑ.

 
 by F1ash on: Mar 6 2011
 
Score 50%

В Панели Настроек плазмоида выбираются отображаемые в панели устройства , и они управляются колесом мыши.
-----------
This is done already.


Reply to this

-

 Re: Re: ÐÑивеÑ.

 
 by bartman2589 on: Mar 6 2011
 
Score 50%

Any answers on what I posted about this plasmoid not working on Kubuntu?


Reply to this

-

 Re: Re: Re: ÐÑивеÑ.

 
 by F1ash on: Mar 6 2011
 
Score 50%

For bartman2589 :
Answer below not for you. I thought about your questions.


Reply to this

-

 Re: Re: Re: Re: ÐÑивеÑ.

 
 by bartman2589 on: Mar 7 2011
 
Score 50%

I know it wasn't for me, but the 'add comment screen' (the one I'm typing this from right now) clearly says near the bottom that "All text must be in English." right below where it has a checkbox for 'Notify me via email of responses to this message.'. There's a reason for that. It's so that on this clearly english speaking site that everyone who visits the site is able to follow along with the comments. The person I pointed this out to needs to be aware of this since they completely ignored it. It doesn't help other people who come here seeking answers if they can't read the comments in the same language as the rest of the site. If they need help in their language they should go to a site in their language or use a translator, for example I don't go to japanese sites and post in english because I know that not everyone there would be able to read my post, it's part of what's called 'Netiquette' or 'Internet Etiquette', just like when you visit a foreign country it's expected that you make an effort to speak in the native language of that country out of respect for that country.


Reply to this

-

 Not Working in Kubuntu 10.10

 
 by kent57 on: Mar 7 2011
 
Score 50%

After installing as per instructions, any use of plasmoid crashes plasma-desktop. Configuring plasmoid crashes desktop and even closing plasmoid crashes desktop. Have followed all discussions above with no success.
Any suggestions?


Reply to this

-

 Re: Not Working in Kubuntu 10.10

 
 by F1ash on: Mar 7 2011
 
Score 50%

I need the output of plasmoidviewer to the console.
Crash usually occur from a premature call to the tracking thread, although the script does not suggest such a possibility.


Reply to this

-

 Re: Not Working in Kubuntu 10.10

 
 by F1ash on: Mar 7 2011
 
Score 50%

Try update plasomiod now (i make some correction).
If this fails, then your PyQt can not kill the thread, using terminate.
Report me about it, please. I try to do a other method to complete the tracking thread.


Reply to this

-

 Re: Re: Not Working in Kubuntu 10.10

 
 by F1ash on: Mar 8 2011
 
Score 50%

Hi, you can update plasmoid ;)
Tested on Fedora14, Kubuntu10.10


Reply to this

goto page:  1  2  3 

Add commentBack






-

-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore




 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Artwork
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
News RSS   
Discussion RSS   
Events RSS   

Participate
Groups
Forum
Add Artwork
Public API
About KDE-Look.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2001-2014 KDE-Look.org Team  
All rights reserved. KDE-Look.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.