-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Artwork
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login



Sponsoring


-
- Content .- Fans (5) .- Knowledge Base  . 

Analog Meter

   0.7  

Plasmoid Script

Score 86%
Analog Meter
zoom


Minimum required   KDE 4.x
Downloads:  2208
Submitted:  Sep 8 2009
Updated:  Jan 13 2012

Description:

Displays various data sources in analog meter

Please send longer messages like patches, bug reports with outputs, etc. to my email.

Plasmoid depends on: plasma-scriptengine-python
Contact: http://bit.ly/damu-email
Browse Source: http://www.gitorious.org/pdamsten/plasmoids/trees/master
Installing: http://userbase.kde.org/Plasma/Installing_Plasmoids




Changelog:

2012-01-13 Version 0.7
* Remove support for KDE 4.3 and lower
* In KDE 4.8 we can\'t have config.ui if want showConfigurationInterface to be called.

2009-10-08 Version 0.6
* Handle system monitor source remove and add

2009-10-07 Version 0.5
* Use only string defaults
* Update data on login

2009-09-11 Version 0.4
* Allow bigger values than 99 to interval
* Update data on start on big intervals

2009-09-10 Version 0.3
* Fix QString/QVariant issues

2009-09-09 Version 0.2
* Show example text in config dialog
* Fix default font

2009-09-08 Version 0.1
* Initial release




LicenseGPL
(Plasmoid)
Send to a friend
Subscribe
Other  Artwork  from pdamsten
Report inappropriate content



goto page: prev   1  2  3 

-

 Min and Max values

 
 by dtiger on: Oct 23 2009
 
Score 50%

Excellent plasmoid.
I use 0.6 version.

But the problem with setting min and max range values.

When I try to set min and max values for my cpu fan with PWM (it spins from 1600 to 2600 rpm) then at current speed of 1600 rpm analog arrow points somewhere to the south-west, out of meter :)

I play with min and max - it's not working right way, for instance, at -1600 and 1600 border values arrow points right to the top, and so on.


Reply to this

-

 Re: Min and Max values

 
 by pdamsten on: Nov 12 2009
 
Score 50%

On my test autorange does not work in big values (>100), but manual min/max seem to work. Do you have value text and does it show values correctly?


Reply to this

-

 Re: Min and Max values

 
 by pdamsten on: Nov 13 2009
 
Score 50%

There was a bug in Plasma::Meter that is now fixed. It only works when minimum is set to 0. So disable autorange and set range manually so that minimum=0. Minimum != 0 will work in KDE 4.4


Reply to this

-

 Unable to configure

 
 by cyberwan on: Nov 12 2009
 
Score 50%

Hi, I'm using this plasmoid on my computer at work, and it works perfectly.
I wanted to install it at home, where my configuration is very similar, but it won't work. I have the python-scriptengine installed so it starts and displays the "Configure" button, but when I click on it, nothing happens. Nothing more when clicking on the configuration tool, or when right-click -> configure.
Am I missing something ?

I'm on KUbuntu 9.10 amd64


The software said "Requires Windows98, Win2000, or better." So I installed Linux.
Reply to this

-

 Re: Unable to configure

 
 by pdamsten on: Nov 12 2009
 
Score 50%

If you run plasmoidviewer analog-meter in konsole does it show any errors?


Reply to this

-

 Re: Re: Unable to configure

 
 by cyberwan on: Nov 12 2009
 
Score 50%

Well, I got "ImportError: No module named klineedit"

Maybe that's because I've been playing with PyQt recently.. Is there some package I can reinstall to clean it up ?


The software said "Requires Windows98, Win2000, or better." So I installed Linux.
Reply to this

-

 Re: Re: Re: Unable to configure

 
 by pdamsten on: Nov 13 2009
 
Score 50%

Try python-kde4


Reply to this

-

 Re: Re: Re: Re: Unable to configure

 
 by cyberwan on: Nov 16 2009
 
Score 50%

Well, it was not as easy as just re-installing the package. PyKDE was installed in a directory not known in python's sys.path. So I added it manually, and now it works perfectly ! Thanks a lot !!


The software said "Requires Windows98, Win2000, or better." So I installed Linux.
Reply to this

-

 Re: Re: Re: Re: Re: Unable to configure

 
 by pumrel on: Jan 14 2012
 
Score 50%

Hey, I have the exact same problem. Can you please help me with the fix?


Reply to this

-

 unit

 
 by hosein-mec2 on: Nov 19 2009
 
Score 50%

I want to see memory in MB instead of KB ! how to do this ?


Reply to this

-

 Re: unit

 
 by pdamsten on: Nov 19 2009
 
Score 50%

Currently analog meter does not support value scales.


Reply to this

-

 Change background

 
 by OdinEidolon on: Mar 14 2010
 
Score 50%

Hi, I use this nice plasmoid to show CPU temperature. Noob question: how could I edit or change the background image, for example to add a red endscale for when temperature is >70°C?


Reply to this

-

 Re: Change background

 
 by pdamsten on: Mar 15 2010
 
Score 50%

Background image comes from Plasma Theme.


Reply to this

-

 Re: Re: Change background

 
 by OdinEidolon on: Mar 15 2010
 
Score 50%

Yeah, I found it. It would be nice if you could include some background image, maybe in a separate package. So that one could have the possibility to choose from many bg while not having to surf many themes.


Reply to this

-

 Re: Change background

 
 by unknownSpirit on: Apr 21 2010
 
Score 50%

I'd really appreciate an object-specific background image, that is every analog meter has its own configurable image.

One more comment on functionality:
Changing sensors after initialisation causes a jumping needle. I guess that the previous configuration is not completely deleted and concurs.


Reply to this

-
.

 crashes plasma in KDE 4.6.2

 
 by vaxxipooh on: Jan 13 2012
 
Score 50%
vaxxipoohvaxxipooh
:: novo vaxxius seclorum ::
Home
-
Ronny Westin 14

:: novo vaxxius seclorum ::
Sweden, Stensele - Västerbottens Län
Last visit 1 day ago
1 Friends
3 Groups

More info
Send a message
Add as friend
Other contents
--

well plasma crashes everytime i try to set it up - i run Linux Mint 10 with KDE 4.6.2 . . .


I am Vaxxipooh and I am totally committed to the festive mode.




Reply to this

-
.

 can not configure source to monitor

 
 by molostoff on: Jan 13 2012
 
Score 50%

selected source field is empty and grayed out and pushing button to select source does nothing. kde 4.7.4 (kubuntu oneiric)


Reply to this

-
.

 Re: can not configure source to monitor

 
 by roctheme on: Jan 13 2012
 
Score 50%

Same here: Kubuntu 64 Kde 4.7.4


Reply to this

-
.

 Re: Re: can not configure source to monitor

 
 by Rudd-O on: Feb 4 2012
 
Score 50%

Same here


Reply to this

-
.

 Re: can not configure source to monitor

 
 by pumrel on: Jan 14 2012
 
Score 50%

Same her :(
debian unstable x64, KDE 4.7.4


Reply to this

-

 Re: can not configure source to monitor

 
 by pdamsten on: Jan 17 2012
 
Score 50%

Do you the latest version. Configuration works here in Kubuntu KDE 4.8 RC2.


Reply to this

-

 Re: Re: can not configure source to monitor

 
 by molostoff on: Jan 17 2012
 
Score 50%

I am confused a little by the following:

Depends on KDE 4.x
Changelog:
2012-01-13 Version 0.7
* In KDE 4.8 we can\'t have config.ui if want showConfigurationInterface to be called.

Latest official KDE version is 4.7.4 (http://kde.org/announcements/announce-4.7.4.php)

Its difficult to imagine reinstalling entire desktop to have RC2 for a plasmoid test, there are a huge number of dependencies all we have from other applications. It is possible to test this plasmoid on virtual desktop system, but I suppose it is better to keep track on usual user needs (me - is usual user, kde 4.7.4) and rely on compatibility with stable and official releases.

I am really wants your plasmoid on my desktop, but its impossible for now :(


Reply to this

-

 Re: Re: Re: can not configure source to monitor

 
 by pdamsten on: Jan 17 2012
 
Score 50%

KDE 4.4 should be enough to run this widget. Just tested it in Kubuntu KDE 4.7.3. So it works here in 4.7.3 and 4.8 RC2. Cannot fix it until I find the problem.


Reply to this

-
.

 Re: Re: Re: Re: can not configure source to monito

 
 by Rudd-O on: Feb 4 2012
 
Score 50%

Doesn't work. KDE 4.8, F16.


Reply to this

-
.

 Re: can not configure source to monito

 
 by berndb on: Mar 6 2012
 
Score 50%

I had the same problem (KDE-4.8.0).
The comment "can't have config.ui..." made me try to delete this file from the installation, and voila... now it works just fine :-)


Reply to this

-
.

 Re: can not configure source to monito

 
 by berndb on: Mar 6 2012
 
Score 50%

I had the same problem (KDE-4.8.0).
The comment "can't have config.ui..." made me try to delete this file from the installation, and voila... now it works just fine :-)


Reply to this

-

 Re: Re: can not configure source to monito

 
 by pdamsten on: Mar 9 2012
 
Score 50%

Thanks for sharing this. When I tested this I renamed the config.ui and hence didn't notice this.



goto page: prev   1  2  3 

Add commentBack






-

-
Do you like or dislike Ubuntu Unity?
 Yes, unity is alien technology!
 It is less confusing than Gnome 3 default, shell.
 Granny thinks it is much more usable than Gnome 2
 Canonical is embarrasing itself with this split project
 Gnome 3 default shell is much better
 I dislike Unity, Gnome 3 default shell is alien technology!
 None of the above, I like the 2Gb for free and Apple alike behavior. Will post a comment instead

resultmore




 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Artwork
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
News RSS   
Discussion RSS   
Events RSS   

Participate
Groups
Forum
Add Artwork
Public API
About KDE-Look.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2001-2014 KDE-Look.org Team  
All rights reserved. KDE-Look.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.